Button Monitor Version 4.05 release note (june o1, 2011)

New 4.05 features: This version was tested on XP/XPe/Windows 7/WES7.

1. Web update checks for new Button Monitor version automatically, or can check update manually.

2. Add OSD (On Screen Display) feature for buttons’ actions and volume display.

3. Added new power saving function and provided new slideshow feature (Digital photo frame, DPF) when power saving
function is enabled and triggered. DPF also provides two different layouts (Full screen or multi-information slideshow)
with background audio (MP3) playback.

DPF features:
v Detect screen resolution automatically and select a suitable layout for users.

All photos / songs included in sub-directories will be identified as soon as you choose a parent directory.

Multi-information includes a photo slideshow, weather, real-time news ticker, calendar and clock information.

Photos and songs can be played randomly.

Volume of background music can be adjustable by using 3 capacitive buttons.
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Customize background color/image in multi-information mode (new).

Detail operation instructions:

1. Main screen changed since version 3.01:

B Newly added “Check available update on startup” option in “Options” tab. Check this to automatically update.
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B Added “Check for Update manually” button in “Options” tab. (See figure 1.)
B Added “Screen Saver” tab, and moved “Power saving” from “Options” tab to this new tab. (fig 1.)

B Added two radio buttons to select power saving method.
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Figure 2
B Added “DPF Advanced Settings” button to launch DPF setting window. (See figure 2.)

2. Automatic Update function:

A. If the auto-check option is on, Button Monitor will check new version from server, and shows a small message

window at bottom-right of screen and disappears when check is done.




Button Monitor
hecking For available update

Figure 3

B. If new version is found, an information window pops up to show the new version availability
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Figure 4

C. Download window pops up, press “Yes” to begin to download, or press “No” to skip.
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Figure 5

D. Once you choose “Yes”, click on “Options” tab to see progress bar as shown below (fig 6)
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Figure 6

E. Button Monitor will be closed and restarted again after new program is updated.

3. Manual Update function:

A. Click on “Check for Update manually” button in “Options” tab to check new version by hand, if new version was
found, all procedures act like Automatic Update feature (see Figure 4~6), if the launched version is the latest one,

you will see this popup message.

iJ update Agent

Mo new version available

Figure 7

B. If system is connected to Internet, but server was down or a problem occurred, message will appear at the

buttom-right corner.

jIJ Update Agent
Can't find IMI file on Internet

Figure 8

C. If the system didn’t connect to Internet, then the update request will be ignored.

4. How to configure DPF feature:

A. Enable “Power saving” feature and select “Start Digital Photo Frame (DPF) feature” in Figure 2, then Click “DPF




Advanced Settings” button for more DPF settings.

B. There're three tabs in DPF setting window, includes Layout, Album and Music tab.
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C. Adjustable parameters in “Layout” tab (Fig 9):

Screen Mode - Provides two different screen layouts — “Full screen slideshow” (Default) and “Slideshow with

multi-information”, see layout example for each different resolution in Table 1.
Note. Weather forecast and news ticker shows only if the unit is connected to Internet.
Show News Ticker — To speed-up loading time of DPF, disable news ticker with “Slideshow with multi-information”.

Note. If you turn on news ticker feature, when slideshow started, the screen might be frozen and hung for few

seconds because Adobe Flash player is busy while loading news information.

Customize Background — In “Slideshow with multi-information” mode, change DPF background style in three ways:
None: Background color is valid only when background image is disabled, user can change the default background color by
clicking on the background color square to select a standard color (Fig 10-1), or Click on “More Color...” button to open Color

Picker Window (Fig 10-2) to define a customize RGB color.
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From File: Click on button a{nd ﬂw avigate to the background image that you want to apply, the background image
supports .BMP or .JPG file and it will be rescaled to fit the screen.

Use default: Button Monitor provides default background image for different resolutions.

Weather source URL — The weather URL in multi-information slideshow can be customized by navigating to FORECA

(http://a.forecabox.com), create your location/style, then save / send the URL to your email to copy the URL here.

Note. To show weather forecast correctly, the size of forecast box must be exactly the same as we designed for each
resolution, all forecast services are provided by FORECA and we don’t take the responsibilities and duties for the contents

of forecast. To learn how to configure Foreca weather forecast, read about Appendix A.

800x600 1024x768

Screen Resolution 1024x600

Size of ForecaBox 720x90 720x90 300x250

News Category — Select category of news to show in news ticker to display 50 articles in all sub-categories regarding the

main category. Main news source is US-based.

Hide Desktop — Check this option to hide desktop icons when slideshow is triggered.
Hide Taskbar — Check this option to hide taskbar when slideshow is triggered.




Detail layout of DPF function in different resolution and mode.

The actual components layout might differ upon versions.

Mode Full screen slideshow

Resolution

Slideshow with Multi-information

(Click on the hyperlink to see larger screenshot)

800x600
(Pro-8/8A)

1024x768
(Pro-15/15A)

1024x600
(Pro-10A)

D. Here are all adjustable parameters in “Album” tab (Figure 11):
Album location — Specify the main directory of album.
You can click on icon to calculate the file count of all
supported type (JPEG, BMP, GIF, PNG) in this directory
(includes all sub directories.)

Note. It doesn’t support Unicode.
Photo Stay time (seconds) — The delay time
between photos. Defaultis 5 sec
Photo order — Specify the order of showing photos,

sequential or randomize (Default).
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Figure 11

Photo Scale - A command that indicates how the DPF function scales the slideshow content:

"None" = content is not scaled in any way. They're simply loaded as-is.

"Crop to Fit" = content will proportionally scale to fill

content area of the component.

"Crop to Fit All" = content scales/crops same as "Crop to Fit" but entire area of the component is used.




"Proportional" = content will proportionally scale to fit the dimensions of component.

"Downscale Only" = content will downscale if larger than the component, but will not be upscaled if smaller.

E. Here are all adjustable parameters in “Music” tab (Figure 12):
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Figure 12
Enable background music feature — Check to play MP3’s while showing slideshow (default ON).
MP3 location — Specify directory of MP3 files. Click icon to calculate file count of .mp3 in this directory (incls sub dir)
Default Volume — Specify the default volume when playing music (default position is 50). 7]
Randomize play list — Check this option to play music files randomly (default is on).
Resume music when activate — Check option for slideshow background music to play since last song/position

(default is off).
Note: MP3 playlist is generated when album list does, if files change in MP3 folder, re-generate list using button in “Album” tab.

F. When the parameters adjustment is completed, click “Save” button to store all changed settings. A confirmation dialog
appears to re-generate the playlist (Figure 13). To increase the power saving speed, Button monitor will generate the
slideshow list only if the list does not exist or the Album location is changed. If you change the files in album directory,

select “Yes” button to re-generate the playlist, or the file will not be updated.

Do you want to re-generate all playlist
(alburm, music) again?

| Yes | | No |

Figure 13

To wake up from power saving mode (background off or slideshow), simply touch the LCD screen or press button on

bezel. @

If slideshow background music feature is enabled, user can adjust volume during slideshow by pressing the following

buttons on bezel, it will have OSD to show the current volume as well.

3 &

Enable/Disable Decrease volume 1 Increase volume 1

audio mute degree degree
Note. Volume control in DPF mode is activated only if the background MP3 is ON. When MP3 is OFF, pressing these buttons will wake unit




Appendix A. How to create a weather forecast URL for Button Monitor DPF feature by using Foreca

1. Open Internet browser and navigate to http://a.forecabox.com
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3.

Choose a location, unit and timeformat,
then click on “Next>>" button.

Choose a customize size and layout, to
fit in the slideshow window exactly, you
have to choose correct size depends on
your LCD resolution, and click on

“Next>>" to continue.

Fill all fields (Name, email and website)
and click on “Submit” so that the forecast

URL will be sent to your mailbox.

Check your mailbox, and get the weather
URL, this URL should be typed in the
“Weather source URL’ field in “DPF
Advanced Settings” window of Button

Monitor. (See Page 3.)




Appendix B.
How to get the Button Monitor?
What shall | do when Button Monitor is launched first time?

1. Download Button Monitor v4.03 and sample albums/mp3:

Button Monitor v4.03: http://www.emink.com/files/ButtonMonitor-v4.03.zip (2.9MB)

Sample Alboum/MP3: http://www.emink.com/files/DPF-samples.zip (20.6MB)

2. Extract and overwrite Button Monitor to c:\Button Monitor
Extract all files in DPF-Sample.zip to c:\sample
3. [Ifit runs under WES7 or Windows 7, locate to c:\Button Monitor, then right-Click on c:\Button Monitor\btnMonitor.exe,

select “Properties”

. Button Monitor =101 x|
o =
(;\ )’o | I + Computer + Local Disk (C:) + Button Monitor ~ I - m‘l Search Button Monitor D]
Organize + Open  New folder = -~ i |®|
Bl Desktop ;I Name “ | Date modified | Type | Size | |
& Downloads
= . Slideshow 5/25/2011 12:13 AM  File folder
= Recent Places
%) bass.dll 1212010 7:47 PM Application extension 99 KB
4 Libraries - ) bnMonities 1112:13AM  Application
= Open
| D its ) dl : icat i
J‘ oc|..|men %] dwiGina2. r&l Run as administrator 5/23/2011 8:10 FM Application extension 39 KB
& Music [EemlcObk Troubleshoot compatibility 10/25/2009 8:35PM  Application 4 KB
E‘ P 2] fwkeyboz  Pin to Taskbar 5/25(2011 12:10 AM  Application extension 156 KB
Videos : Unpin from Start M
%] fuMousel - P rem Startfend 5/25/2011 12:10 AM  Application extension 140 KB
Restore previous versions
“a Homegroup Q mkMirrar, —— , 3/10/2011 8:13PM Application 1,925KB
|# | style.ini 11/12(2009 7:39 PM IMI File 1KB
M Computer Y verify.ex  Cut 10/20/2009 12:57 AM  Application 434KB
o . Copy
£ Local Disk (1) %] winTo.di 3/1/2002 §:22 AM Application extension 4B KB
Create shortcut
F- S =l Delete
z % btnMonitor.exe Date modified; ated: 4/29/2011 3:40PM
: ' Application Sizef .

Select “Compatibility” page, enable “Run this program in compatibility mode for” checkbox, then select “Windows XP

(Service Pack 3)".

Enable “Run this program as an administrator” checkbox, then click “OK” to save & close.

i — X
General Securi‘fyl Details I Previous Versions |

If you have problems with this program and it worked comectly on
an earlier version of Windows, select the compatibility mode that
matches that earlier version.
Help me choose the settings
—Ct mode

¥ Run this program in compatibilty mode for:
I‘Nlndows ¥P (Service Pack 3) j

~ Settings
™ Run in 256 colors

™ Run in 640 x 480 screen resolution
[ Disable visual themes

™ Disable desktop composition

™ Disable display scaling on high DP settings

i i~ Privilege Level
¥ Run this program as an administrator

Change settings for all users |

[ o | coma |_ e |

4. Launch c:\Button Monitor\btnMonitor.exe

5. These options can be checked so that Button Monitor can serve at background.
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Click on “Check for Update manually” button to get the latest version of Button Monitor online.

Enable button1~4 function depends on your need.
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8. Adjust power saving feature, choose what kind of power saving type.
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Deactivate

Status  Options  Button 1

Minimum to tray Exit

Button 2 Button3 Button4 | Screen Saver

If the power saving function is ON, and you want to

use DPF feature, click on “DPF Advanced Settings”.

o Power Saving - Trigger power saving function after El minutes

(20 Turn off LCD backlight

1@ Start Digikal Photo Frame (DPF) feature

DPF Advanced Settings
- il
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¥ Hide Desktop ¥ Hide Taskhar
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W Show Meves Ticker

Step 1.

Select Screen Mode
Step 2.
Type in  Weather URL

http://a.forecabox.com/get/2

9328
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Step 3. If you enable news ticker, select a news category.

Step 4. Go to “Music” page.

:E W Enable background music feature @

Layout MP3 location -

el

E —
All:uum@ Default Yolume m

¥ Randomize play list
0 ¥ Resume music when activate

| Dsampleimps
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Pas: 30

'Il!_"'. Save

Music

‘ Cancel

Step 5. Enable/Disable background music feature (MP3 Only)

Step 6. Click here to browse and choose the MP3 folder location. (Ex. C:\sample\MP3)
Step 7. Click here to calculate the available MP3 files.

Step 8. Miscellaneous options of background music.

Step 9. Go to “Album” page.

1 Album location -

LE].{D T | Chsamplealbum @“
Length: 5 secon
Photo Skay time - ———1]
@ Photo order - ) Sequential @ Random @
Album

& Re-generate list manually if thecontents in directory are changed @
'Il!_"', Save ‘ Cancel

Step 10. Click here to browse and choose the photo folder location. (Ex. C:\sample\album)

Music

Step 11. Click here to calculate the available photo files
Step 12. Miscellaneous options of album
Step 13. Click this button to generate playlist

Step 14. Click on “Save” button to save settings and close this window.

Wait for the DPF function to activate after the minutes that you specified.

this is Denver @720x90




